华为无线网络射频调优及WLAN跨VLAN的三层漫游示例

1.业务需求

  • 企业用户通过WLAN接入网络,以满足移动办公的最基本需求。
  • 在覆盖区域内移动发生跨VLAN的漫游时,不影响用户的业务使用。

2.组网需求

  • AC组网方式:旁挂三层组网。
  • DHCP部署方式:
    • AC作为DHCP服务器为AP分配IP地址。
    • 汇聚交换机SwitchB作为DHCP服务器为STA分配IP地址。
  • 业务数据转发方式:直接转发。
图片[1]-华为无线网络射频调优及WLAN跨VLAN的三层漫游示例-不念博客

3.数据规划

AC数据表规划如下:

图片[2]-华为无线网络射频调优及WLAN跨VLAN的三层漫游示例-不念博客

4.配置思路

1)配置APAC和周边网络设备之间实现网络互通。

2)配置AP上线。

  • 创建AP组,用于将需要进行相同配置的AP都加入到AP组,实现统一配置。
  • 配置AC的系统参数,包括国家码、ACAP之间通信的源接口。
  • 配置AP上线的认证方式并离线导入AP,实现AP正常上线。

3)配置WLAN业务参数,实现STA访问WLAN网络功能。

说明:

当用户新开局时,对于AP的射频信道的设置,用户可根据网络规划手动指定,也可使用射频调优功能自动选择最佳信道。

本例中采用射频调优功能自动选择最佳信道。

5.操作步骤

5.1、配置周边设备

配置接入交换机SwitchA:

  • GE0/0/1接口加入VLAN10VLAN101
  • GE0/0/2接口加入VLAN10VLAN101VLAN102
  • GE0/0/3接口加入VLAN10VLAN102
  • GE0/0/1GE0/0/3接口的缺省VLANVLAN10
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 10 101 102
[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type trunk
[SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 10
[SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 101
[SwitchA-GigabitEthernet0/0/1] port-isolate enable
[SwitchA-GigabitEthernet0/0/1] quit
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type trunk
[SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 10 101 102
[SwitchA-GigabitEthernet0/0/2] quit
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] port link-type trunk
[SwitchA-GigabitEthernet0/0/3] port trunk pvid vlan 10
[SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 10 102
[SwitchA-GigabitEthernet0/0/3] port-isolate enable
[SwitchA-GigabitEthernet0/0/3] quit

配置汇聚交换机SwitchB:

  • 接口GE0/0/1加入VLAN10VLAN101VLAN102
  • 接口GE0/0/2加入VLAN100
  • 接口GE0/0/3加入VLAN101VLAN102
  • 创建接口VLANIF100,地址为10.23.100.2/24
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 10 100 101 102
[SwitchB] interface gigabitethernet 0/0/1
[SwitchB-GigabitEthernet0/0/1] port link-type trunk
[SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 101 102
[SwitchB-GigabitEthernet0/0/1] quit
[SwitchB] interface gigabitethernet 0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type trunk
[SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
[SwitchB-GigabitEthernet0/0/2] quit
[SwitchB] interface gigabitethernet 0/0/3
[SwitchB-GigabitEthernet0/0/3] port link-type trunk
[SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101 102
[SwitchB-GigabitEthernet0/0/3] quit
[SwitchB] interface vlanif 100
[SwitchB-Vlanif100] ip address 10.23.100.2 24
[SwitchB-Vlanif100] quit

配置Router的接口:

  • 接口GE1/0/0加入VLAN101VLAN102
  • 创建接口VLANIF101并配置IP地址为10.23.101.2/24
  • 创建接口VLANIF102并配置IP地址为10.23.102.2/24
<Huawei> system-view
[Huawei] sysname Router
[Router] vlan batch 101 102
[Router] interface gigabitethernet 1/0/0
[Router-GigabitEthernet1/0/0] port link-type trunk
[Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101 102
[Router-GigabitEthernet1/0/0] quit
[Router] interface vlanif 101
[Router-Vlanif101] ip address 10.23.101.2 24
[Router-Vlanif101] quit
[Router] interface vlanif 102
[Router-Vlanif102] ip address 10.23.102.2 24
[Router-Vlanif102] quit

5.2、配置AC与其它网络设备互通

# 配置AC的接口GE0/0/1加入VLAN100,并创建接口VLANIF100

<AC6605> system-view
[AC6605] sysname AC
[AC] vlan 100
[AC-vlan100] quit
[AC] interface vlanif 100
[AC-Vlanif100] ip address 10.23.100.1 24
[AC-Vlanif100] quit
[AC] interface gigabitethernet 0/0/1
[AC-GigabitEthernet0/0/1] port link-type trunk
[AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
[AC-GigabitEthernet0/0/1] quit

配置ACAP的路由,下一跳为SwitchBVLANIF100

[AC] ip route-static 10.23.10.0 24 10.23.100.2

5.3、配置DHCP服务为AP和STA分配IP地址

# 在SwitchB上配置DHCP中继,代理AC分配IP地址

[SwitchB] dhcp enable
[SwitchB] interface vlanif 10
[SwitchB-Vlanif10] ip address 10.23.10.1 24
[SwitchB-Vlanif10] dhcp select relay
[SwitchB-Vlanif10] dhcp relay server-ip 10.23.100.1
[SwitchB-Vlanif10] quit

SwitchB上创建VLANIF101VLANIF102接口为STA提供地址,并指定默认网关

说明:

DNS服务器地址请根据实际需要配置。常用配置方法如下:

  • 接口地址池场景,需要在VLANIF接口视图下执行命令dhcp server dns-list ip-address &<1-8>。
  • 全局地址池场景,需要在IP地址池视图下执行命令dns-list ip-address &<1-8>。
[SwitchB] interface vlanif 101
[SwitchB-Vlanif101] ip address 10.23.101.1 24
[SwitchB-Vlanif101] dhcp select interface
[SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
[SwitchB-Vlanif101] quit
[SwitchB] interface vlanif 102
[SwitchB-Vlanif102] ip address 10.23.102.1 24
[SwitchB-Vlanif102] dhcp select interface
[SwitchB-Vlanif102] dhcp server gateway-list 10.23.102.2
[SwitchB-Vlanif102] quit

# 在AC上创建全局地址池为AP提供地址

[AC] dhcp enable
[AC] ip pool huawei
[AC-ip-pool-huawei] network 10.23.10.0 mask 24
[AC-ip-pool-huawei] gateway-list 10.23.10.1
[AC-ip-pool-huawei] option 43 sub-option 3 ascii 10.23.100.1
[AC-ip-pool-huawei] quit
[AC] interface vlanif 100
[AC-Vlanif100] dhcp select global
[AC-Vlanif100] quit

5.4、配置AP上线

# 创建AP

用于将相同配置的AP都加入同一AP组中。

[AC] wlan
[AC-wlan-view] ap-group name ap-group1
[AC-wlan-ap-group-ap-group1] quit
[AC-wlan-view] ap-group name ap-group2
[AC-wlan-ap-group-ap-group2] quit

创建域管理模板

在域管理模板下配置AC的国家码并在AP组下引用域管理模板。

[AC-wlan-view] regulatory-domain-profile name default
[AC-wlan-regulate-domain-default] country-code cn
[AC-wlan-regulate-domain-default] quit

[AC-wlan-view] ap-group name ap-group1
[AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
e?[Y/N]:y 
[AC-wlan-ap-group-ap-group1] quit

[AC-wlan-view] ap-group name ap-group2
[AC-wlan-ap-group-ap-group2] regulatory-domain-profile default
Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
e?[Y/N]:y 
[AC-wlan-ap-group-ap-group2] quit
[AC-wlan-view] quit

配置AC的源接口

[AC] capwap source interface vlanif 100

注册AP

AC上离线导入AP,并将area_1area_2分别加入APap-group1ap-group2中。

假设APMAC地址为60de-4476-e360,并且根据AP的部署位置为AP配置名称,便于从名称上就能够了解AP的部署位置。例如MAC地址为60de-4476-e360AP部署在1号区域,命名此AParea_1

[AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
[AC-wlan-ap-0] ap-name area_1
Warning: This operation may cause AP reset. Continue? [Y/N]:y 
[AC-wlan-ap-0] ap-group ap-group1
Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
s of the radio, Whether to continue? [Y/N]:y 
[AC-wlan-ap-0] quit
[AC-wlan-view] ap-id 1 ap-mac dcd2-fc04-b500
[AC-wlan-ap-1] ap-name area_2
Warning: This operation may cause AP reset. Continue? [Y/N]:y 
[AC-wlan-ap-1] ap-group ap-group2
Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
s of the radio, Whether to continue? [Y/N]:y 
[AC-wlan-ap-1] quit

注:

AP上电后,当执行命令display ap all查看到APState字段为nor时,表示AP正常上线。

5.5、配置WLAN业务参数

创建名为wlan-net的安全模板,并配置安全策略。

[AC-wlan-view] security-profile name wlan-net
[AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
[AC-wlan-sec-prof-wlan-net] quit

创建名为wlan-netSSID模板,并配置SSID名称为wlan-net

[AC-wlan-view] ssid-profile name wlan-net
[AC-wlan-ssid-prof-wlan-net] ssid wlan-net
[AC-wlan-ssid-prof-wlan-net] quit

创建名为wlan-net1wlan-net2VAP模板,配置业务数据转发模式、业务VLAN,并且引用安全模板和SSID模板。

[AC-wlan-view] vap-profile name wlan-net1
[AC-wlan-vap-prof-wlan-net1] service-vlan vlan-id 101
[AC-wlan-vap-prof-wlan-net1] security-profile wlan-net
[AC-wlan-vap-prof-wlan-net1] ssid-profile wlan-net
[AC-wlan-vap-prof-wlan-net1] quit
[AC-wlan-view] vap-profile name wlan-net2
[AC-wlan-vap-prof-wlan-net2] service-vlan vlan-id 102
[AC-wlan-vap-prof-wlan-net2] security-profile wlan-net
[AC-wlan-vap-prof-wlan-net2] ssid-profile wlan-net
[AC-wlan-vap-prof-wlan-net2] quit

配置AP组引用VAP模板,area_1上射频0和射频1都使用VAP模板wlan-net1的配置,area_2上射频0和射频1都使用VAP模板wlan-net2的配置。

[AC-wlan-view] ap-group name ap-group1
[AC-wlan-ap-group-ap-group1] vap-profile wlan-net1 wlan 1 radio 0
[AC-wlan-ap-group-ap-group1] vap-profile wlan-net1 wlan 1 radio 1
[AC-wlan-ap-group-ap-group1] quit
[AC-wlan-view] ap-group name ap-group2
[AC-wlan-ap-group-ap-group2] vap-profile wlan-net2 wlan 1 radio 0
[AC-wlan-ap-group-ap-group2] vap-profile wlan-net2 wlan 1 radio 1
[AC-wlan-ap-group-ap-group2] quit

5.6、开启射频调优功能自动选择AP最佳信道和功率

# 使能射频的信道和功率自动调优功能。

[AC-wlan-view] ap-group name ap-group1
[AC-wlan-ap-group-ap-group1] radio 0
[AC-wlan-group-radio-ap-group1/0] undo calibrate auto-channel-select disable
[AC-wlan-group-radio-ap-group1/0] undo calibrate auto-txpower-select disable
[AC-wlan-group-radio-ap-group1/0] quit
[AC-wlan-ap-group-ap-group1] radio 1
[AC-wlan-group-radio-ap-group1/1] undo calibrate auto-channel-select disable
[AC-wlan-group-radio-ap-group1/1] undo calibrate auto-txpower-select disable
[AC-wlan-group-radio-ap-group1/1] quit
[AC-wlan-ap-group-ap-group1] quit
[AC-wlan-view] ap-group name ap-group2
[AC-wlan-ap-group-ap-group2] radio 0
[AC-wlan-group-radio-ap-group2/0] undo calibrate auto-channel-select disable
[AC-wlan-group-radio-ap-group2/0] undo calibrate auto-txpower-select disable
[AC-wlan-group-radio-ap-group2/0] quit
[AC-wlan-ap-group-ap-group2] radio 1
[AC-wlan-group-radio-ap-group2/1] undo calibrate auto-channel-select disable
[AC-wlan-group-radio-ap-group2/1] undo calibrate auto-txpower-select disable
[AC-wlan-group-radio-ap-group2/1] quit
[AC-wlan-ap-group-ap-group2] quit

在域管理模板下配置调优信道集合

[AC-wlan-view] regulatory-domain-profile name default
[AC-wlan-regulate-domain-default] dca-channel 2.4g channel-set 1,6,11
[AC-wlan-regulate-domain-default] dca-channel 5g bandwidth 20mhz
[AC-wlan-regulate-domain-default] dca-channel 5g channel-set 149,153,157,161
[AC-wlan-regulate-domain-default] quit

创建空口扫描模板wlan-airscan,并配置调优信道集合、扫描间隔时间和扫描持续时间。

[AC-wlan-view] air-scan-profile name wlan-airscan
[AC-wlan-air-scan-prof-wlan-airscan] scan-channel-set dca-channel
[AC-wlan-air-scan-prof-wlan-airscan] scan-period 60
[AC-wlan-air-scan-prof-wlan-airscan] scan-interval 60000
[AC-wlan-air-scan-prof-wlan-airscan] quit

创建2G射频模板wlan-radio2g,并在该模板下引用空口扫描模板wlan-airscan

[AC-wlan-view] radio-2g-profile name wlan-radio2g 
[AC-wlan-radio-2g-prof-wlan-radio2g] air-scan-profile wlan-airscan
[AC-wlan-radio-2g-prof-wlan-radio2g] quit

创建5G射频模板wlan-radio5g,并在该模板下引用空口扫描模板wlan-airscan

[AC-wlan-view] radio-5g-profile name wlan-radio5g 
[AC-wlan-radio-5g-prof-wlan-radio5g] air-scan-profile wlan-airscan
[AC-wlan-radio-5g-prof-wlan-radio5g] quit

在名为ap-group1ap-group2的AP组下引用5G射频模板wlan-radio5g2G射频模板wlan-radio2g

[AC-wlan-view] ap-group name ap-group1
[AC-wlan-ap-group-ap-group1] radio-5g-profile wlan-radio5g radio 1
Warning: This action may cause service interruption. Continue?[Y/N]y
[AC-wlan-ap-group-ap-group1] radio-2g-profile wlan-radio2g radio 0
Warning: This action may cause service interruption. Continue?[Y/N]y
[AC-wlan-ap-group-ap-group1] quit
[AC-wlan-view] ap-group name ap-group2
[AC-wlan-ap-group-ap-group2] radio-5g-profile wlan-radio5g radio 1
Warning: This action may cause service interruption. Continue?[Y/N]y
[AC-wlan-ap-group-ap-group2] radio-2g-profile wlan-radio2g radio 0
Warning: This action may cause service interruption. Continue?[Y/N]y
[AC-wlan-ap-group-ap-group2] quit

配置射频调优模式为手动调优,并手动触发射频调优

[AC-wlan-view] calibrate enable manual
[AC-wlan-view] calibrate manual startup

待执行手动调优一小时后,调优结束。将射频调优模式改为定时调优,并将调优时间定为用户业务空闲时段(如当地时间凌晨00:00-06:00时段)。

[AC-wlan-view] calibrate enable schedule time 03:00:00

5.7、验证配置结果

WLAN业务配置会自动下发给AP,配置完成后,通过执行命令display vap ssid wlan-net查看如下信息,当Status项显示为ON时,表示AP对应的射频上的VAP已创建成功。

[AC-wlan-view] display vap ssid wlan-net
Info: This operation may take a few seconds, please wait.
WID : WLAN ID
--------------------------------------------------------------------------------
AP ID AP name RfID WID     BSSID          Status  Auth type     STA   SSID
--------------------------------------------------------------------------------
0     area_1  0    1       60DE-4476-E360 ON      WPA/WPA2-PSK  0     wlan-net
0     area_1  1    1       60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
1     area_2  0    1       60DE-4474-9640 ON      WPA/WPA2-PSK  0     wlan-net
1     area_2  1    1       60DE-4474-9650 ON      WPA/WPA2-PSK  0     wlan-net
-------------------------------------------------------------------------------
Total: 4

STA搜索到名为wlan-net的无线网络,输入密码a1234567并正常关联后,在AC上执行display station ssid wlan-net命令,可以查看到用户已经接入到无线网络wlan-net中。

[AC-wlan-view] display station ssid wlan-net
Rf/WLAN: Radio ID/WLAN ID
Rx/Tx: link receive rate/link transmit rate(Mbps)
---------------------------------------------------------------------------------
STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
---------------------------------------------------------------------------------
e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
---------------------------------------------------------------------------------
Total: 1 2.4G: 0 5G: 1

STAAP1的覆盖范围移动到AP2的覆盖范围时,在AC上执行命令display station ssid wlan-net,查看STA的接入信息,可以看到STA关联到了AP2

[AC-wlan-view] display station ssid wlan-net
Rf/WLAN: Radio ID/WLAN ID                                                     
Rx/Tx: link receive rate/link transmit rate(Mbps)                             
----------------------------------------------------------------------------------------
STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address     
----------------------------------------------------------------------------------------
e019-1dc7-1e08   1     area_2   1/1      5G    11n   46/59      -58   101   10.23.101.254
----------------------------------------------------------------------------------------
Total: 1 2.4G: 0 5G: 1

AC上执行命令display station roam-track sta-mac e019-1dc7-1e08,可以查看该STA的漫游轨迹。

[AC-wlan-view] display station roam-track sta-mac e019-1dc7-1e08
Access SSID:wlan-net    
Rx/Tx:link receive rate/link transmit rate(Mbps) 
c:PMK Cache Roam r:802.11r Roam s:Same Frequency Network
------------------------------------------------------------------------------
L2/L3           AC IP                  AP name              Radio ID
BSSID           TIME                   In/Out RSSI          Out Rx/Tx
------------------------------------------------------------------------------
--              10.23.100.1            area_1               1
60DE-4476-E370  2016/01/12 16:52:58    -51/-48              46/13
L3              10.23.100.1            area_2               1
60DE-4474-9650  2016/01/12 16:55:45    -58/-                -/-
------------------------------------------------------------------------------
Number: 1

【PDF文件及CFG配置文件获取方法】:

huaweiwuxianwangluoshepindiaoyoujiwlankuavlandesancengmanyou.zip
zip文件
© 版权声明
THE END
喜欢就支持一下吧
点赞133赞赏 分享
评论 抢沙发
头像
欢迎光临不念博客,留下您的想法和建议,祝您有愉快的一天~
提交
头像

昵称

取消
昵称代码图片

    暂无评论内容